aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-Nagios-Plugin-Beanstalk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/p5-Nagios-Plugin-Beanstalk/Makefile')
-rw-r--r--net-mgmt/p5-Nagios-Plugin-Beanstalk/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-mgmt/p5-Nagios-Plugin-Beanstalk/Makefile b/net-mgmt/p5-Nagios-Plugin-Beanstalk/Makefile
new file mode 100644
index 000000000000..0328d1fce4ec
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugin-Beanstalk/Makefile
@@ -0,0 +1,26 @@
+# Created by: Andrew Thompson <thompsa@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= Nagios-Plugin-Beanstalk
+PORTVERSION= 0.04
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:GBARR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Module to check beanstalkd via nagios
+
+BUILD_DEPENDS= p5-Nagios-Plugin>=0:${PORTSDIR}/net-mgmt/p5-Nagios-Plugin \
+ p5-Beanstalk-Client>=0:${PORTSDIR}/net/p5-Beanstalk-Client
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
+ ${INSTALL} ${WRKSRC}/check_beanstalkd ${STAGEDIR}${PREFIX}/libexec/nagios/check_beanstalkd
+
+.include <bsd.port.mk>