aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile35
1 files changed, 23 insertions, 12 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index ebff70b8cea9..fd931e01049f 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pmacct
-DISTVERSION= 0.12.5
-PORTREVISION= 1
+DISTVERSION= 0.14.0
CATEGORIES= net-mgmt
MASTER_SITES= http://www.pmacct.net/ \
http://mirrors.rit.edu/zi/
@@ -23,18 +22,20 @@ GNU_CONFIGURE= yes
CPPFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
-OPTIONS= MYSQL "Enable MySQL support." Off \
- PGSQL "Enable PostgreSQL support." Off \
- SQLITE "Enable SQLite support." Off \
- THREADS "Enable multi-threading." Off \
- MMAP "Enable mmap(2) support." On \
- LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" On \
- IPV6 "Enable IPv6 support." On
+OPTIONS= MYSQL "Enable MySQL support" off \
+ PGSQL "Enable PostgreSQL support" off \
+ SQLITE "Enable SQLite support" off \
+ THREADS "Enable multi-threading" off \
+ MMAP "Enable mmap(2) support" on \
+ LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" on \
+ IPV6 "Enable IPv6 support" on \
+ SHARED "Enable shared objects" on \
+ DEBUG "Enable debugging" off
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-CONFIGURE_ARGS+= --enable-64bit
+CONFIGURE_ARGS+=--enable-64bit
.endif
.if defined(WITH_MYSQL)
@@ -42,7 +43,7 @@ USE_MYSQL= yes
CONFIGURE_ARGS+=--enable-mysql
PLIST_SUB+= WITH_MYSQL=""
.else
-CONFIGURE_ARGS+= --disable-mysql
+CONFIGURE_ARGS+=--disable-mysql
PLIST_SUB+= WITH_MYSQL="@comment "
.endif
@@ -51,7 +52,7 @@ USE_PGSQL= yes
CONFIGURE_ARGS+=--enable-pgsql
PLIST_SUB+= WITH_PGSQL=""
.else
-CONFIGURE_ARGS+= --disable-pgsql
+CONFIGURE_ARGS+=--disable-pgsql
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
@@ -87,12 +88,22 @@ CONFIGURE_ARGS+=--enable-threads
CONFIGURE_ARGS+=--disable-threads
.endif
+.if defined(WITHOUT_SHARED)
+CONFIGURE_ARGS+=--disable-so
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
post-install:
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in ChangeLog EXAMPLES FAQS README