aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix2-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/zabbix2-server/Makefile')
-rw-r--r--net-mgmt/zabbix2-server/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 4d95b50305d6..8e37a8b75f10 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zabbix2
PORTVERSION= 2.0.20
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
@@ -125,7 +125,11 @@ JAVAGW_USE= JAVA=yes
post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
- @${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' ${WRKSRC}/conf/zabbix_*.conf
+ @${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' \
+ ${WRKSRC}/conf/zabbix_*.conf \
+ ${WRKSRC}/src/zabbix_proxy/proxy.c \
+ ${WRKSRC}/src/zabbix_server/server.c
+
.if ${ZABBIX_BUILD} != "agent"
.for d in mysql oracle postgresql sqlite3