aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/py3-dnsdiag/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-mgmt/py3-dnsdiag/Makefile b/net-mgmt/py3-dnsdiag/Makefile
index 3aa5004c628e..128466089e1f 100644
--- a/net-mgmt/py3-dnsdiag/Makefile
+++ b/net-mgmt/py3-dnsdiag/Makefile
@@ -18,4 +18,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.15.0:dns/py-dnspython \
USES= python:3.3+
USE_PYTHON= autoplist distutils
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>