aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile17
-rw-r--r--net-mgmt/collectd5/pkg-plist3
2 files changed, 18 insertions, 2 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 47c91b4aa4be..a08d06bfaa9a 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -15,14 +15,16 @@ USES= gmake pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= aclocal autoconf autoheader automake libltdl libtool
-USE_GNOME= glib20
+
+# Only autoconf stage and sigrok plugin need GLIB:
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc:${PORTSDIR}/devel/glib20
OPTIONS_DEFINE= CGI DEBUG GCRYPT VIRT
OPTIONS_GROUP= INPUT OUTPUT
OPTIONS_GROUP_OUTPUT= RRDTOOL NOTIFYEMAIL NOTIFYDESKTOP
OPTIONS_GROUP_INPUT= CURL DBI JSON MEMCACHEC MODBUS MYSQL \
NUTUPS PGSQL PING PYTHON RABBITMQ REDIS \
- ROUTEROS SNMP STATGRAB TOKYOTYRANT XML XMMS
+ ROUTEROS SIGROK SNMP STATGRAB TOKYOTYRANT XML XMMS
CGI_DESC= Install collection.cgi (requires rrdtool)
CURL_DESC= Enable curl-based plugins (apache, nginx, etc)
@@ -43,6 +45,7 @@ RABBITMQ_DESC= Enable rabbitmq-based plugins
REDIS_DESC= Enable redis-based plugins
ROUTEROS_DESC= Enable routeros plugin
RRDTOOL_DESC= Enable rrdtool plugin (also rrdcached plugin)
+SIGROK_DESC= Enable sigrok plugin
SNMP_DESC= Enable SNMP plugin
STATGRAB_DESC= Enable statgrab-based plugins (disk, interface, etc)
TOKYOTYRANT_DESC= Enable tokyotyrant plugin
@@ -364,6 +367,16 @@ PLIST_SUB+= USERS=""
PLIST_SUB+= USERS="@comment "
.endif
+.if ${PORT_OPTIONS:MSIGROK}
+USE_GNOME+= glib20
+LIB_DEPENDS+= libsigrok.so:${PORTSDIR}/devel/libsigrok
+CONFIGURE_ARGS+=--with-libsigrok --enable-sigrok
+PLIST_SUB+= SIGROK=""
+.else
+CONFIGURE_ARGS+=--disable-sigrok
+PLIST_SUB+= SIGROK="@comment "
+.endif
+
.if ${PORT_OPTIONS:MSNMP}
LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+=--with-libnetsnmp --enable-snmp
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 1e705467bd66..e3a30cbdc019 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -154,6 +154,9 @@ lib/collectd/processes.la
%%RRDTOOL%%lib/collectd/rrdtool.a
%%RRDTOOL%%lib/collectd/rrdtool.so
%%RRDTOOL%%lib/collectd/rrdtool.la
+%%SIGROK%%lib/collectd/sigrok.a
+%%SIGROK%%lib/collectd/sigrok.la
+%%SIGROK%%lib/collectd/sigrok.so
%%SNMP%%lib/collectd/snmp.a
%%SNMP%%lib/collectd/snmp.so
%%SNMP%%lib/collectd/snmp.la