aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix-server/Makefile12
-rw-r--r--net-mgmt/zabbix-server/distinfo6
-rw-r--r--net-mgmt/zabbix-server/pkg-plist.frontend11
-rw-r--r--net-mgmt/zabbix2-server/Makefile12
-rw-r--r--net-mgmt/zabbix2-server/distinfo6
-rw-r--r--net-mgmt/zabbix2-server/pkg-plist.frontend11
6 files changed, 46 insertions, 12 deletions
diff --git a/net-mgmt/zabbix-server/Makefile b/net-mgmt/zabbix-server/Makefile
index 83c0dc2c5a06..643abd7e7b53 100644
--- a/net-mgmt/zabbix-server/Makefile
+++ b/net-mgmt/zabbix-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zabbix
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.2
PORTREVISION?= 0
PORTEPOCH= 2
CATEGORIES= net-mgmt
@@ -61,7 +61,8 @@ OPTIONS= MYSQL "Use MySQL backend" on \
IPV6 "Support for IPv6" on \
LDAP "Support for checking LDAP servers" on \
JABBER "Use jabber media type" on \
- FPING "Use fping for pinging hosts" on
+ FPING "Use fping for pinging hosts" on \
+ SSH "Use libssh2 for SSH-based checks" off
.include <bsd.port.options.mk>
@@ -75,7 +76,7 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
.elifdef WITH_SQLITE
ZABBIX_REQUIRE=
-USE_SQLITE= yes
+USE_SQLITE= 3
CONFIGURE_ARGS+= --with-sqlite3
.else
IGNORE= zabbix requires a database backend
@@ -94,6 +95,11 @@ CONFIGURE_ARGS+= --with-jabber
.ifndef WITHOUT_FPING
RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
+
+.ifdef WITH_SSH
+LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
+CONFIGURE_ARGS+= --with-ssh2
+.endif
.endif # if ${ZABBIX_BUILD} != "agent"
.ifdef WITH_IPV6
diff --git a/net-mgmt/zabbix-server/distinfo b/net-mgmt/zabbix-server/distinfo
index da5e3d690fe6..993d92207709 100644
--- a/net-mgmt/zabbix-server/distinfo
+++ b/net-mgmt/zabbix-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (zabbix-1.8.1.tar.gz) = ab1a5006a885d780084bb870320abbc9
-SHA256 (zabbix-1.8.1.tar.gz) = ef487766f22527d79fd7a2631b615c34d04103038341f1dc16eceb77172d8a7c
-SIZE (zabbix-1.8.1.tar.gz) = 3607414
+MD5 (zabbix-1.8.2.tar.gz) = fa4be4fa7ac20a33cc0aa5c27b827746
+SHA256 (zabbix-1.8.2.tar.gz) = ba1d00454551c1c6f0d270f76718b69ce9f54c427e22acb5a13ccbc9e621fd81
+SIZE (zabbix-1.8.2.tar.gz) = 3706540
diff --git a/net-mgmt/zabbix-server/pkg-plist.frontend b/net-mgmt/zabbix-server/pkg-plist.frontend
index 621b136ab5df..ce99d0de6175 100644
--- a/net-mgmt/zabbix-server/pkg-plist.frontend
+++ b/net-mgmt/zabbix-server/pkg-plist.frontend
@@ -12,6 +12,7 @@
%%WWWDIR%%/api/classes/class.cgraphitem.php
%%WWWDIR%%/api/classes/class.chost.php
%%WWWDIR%%/api/classes/class.chostgroup.php
+%%WWWDIR%%/api/classes/class.cimage.php
%%WWWDIR%%/api/classes/class.citem.php
%%WWWDIR%%/api/classes/class.cmaintenance.php
%%WWWDIR%%/api/classes/class.cmap.php
@@ -54,6 +55,7 @@
%%WWWDIR%%/config.php
%%WWWDIR%%/css.css
%%WWWDIR%%/dashboard.php
+%%WWWDIR%%/dashconf.php
%%WWWDIR%%/discovery.php
%%WWWDIR%%/discoveryconf.php
%%WWWDIR%%/events.php
@@ -90,6 +92,10 @@
%%WWWDIR%%/images/general/bttn/arrowright_bb.png
%%WWWDIR%%/images/general/bttn/arrowup.png
%%WWWDIR%%/images/general/bttn/arrowup_bb.png
+%%WWWDIR%%/images/general/bttn/config.png
+%%WWWDIR%%/images/general/bttn/config_bb.png
+%%WWWDIR%%/images/general/bttn/config_hl.png
+%%WWWDIR%%/images/general/bttn/config_hl_bb.png
%%WWWDIR%%/images/general/bttn/down.png
%%WWWDIR%%/images/general/bttn/down_bb.png
%%WWWDIR%%/images/general/bttn/fullscreen.png
@@ -128,6 +134,7 @@
%%WWWDIR%%/images/general/ipmi_available_bb.png
%%WWWDIR%%/images/general/ipmi_unavailable.png
%%WWWDIR%%/images/general/ipmi_unknown.png
+%%WWWDIR%%/images/general/no_icon.png
%%WWWDIR%%/images/general/ok.png
%%WWWDIR%%/images/general/ok_bb.png
%%WWWDIR%%/images/general/ok_icon.png
@@ -286,6 +293,7 @@
%%WWWDIR%%/include/config.inc.php
%%WWWDIR%%/include/copt.lib.php
%%WWWDIR%%/include/db.inc.php
+%%WWWDIR%%/include/debug.inc.php
%%WWWDIR%%/include/defines.inc.php
%%WWWDIR%%/include/discovery.inc.php
%%WWWDIR%%/include/events.inc.php
@@ -296,6 +304,7 @@
%%WWWDIR%%/include/hosts.inc.php
%%WWWDIR%%/include/html.inc.php
%%WWWDIR%%/include/httptest.inc.php
+%%WWWDIR%%/include/ident.inc.php
%%WWWDIR%%/include/images.inc.php
%%WWWDIR%%/include/items.inc.php
%%WWWDIR%%/include/js.inc.php
@@ -315,6 +324,7 @@
%%WWWDIR%%/include/locales/ru_ru.inc.php
%%WWWDIR%%/include/locales/sp_sp.inc.php
%%WWWDIR%%/include/locales/sv_se.inc.php
+%%WWWDIR%%/include/locales/ua_ua.inc.php
%%WWWDIR%%/include/maintenances.inc.php
%%WWWDIR%%/include/maps.inc.php
%%WWWDIR%%/include/media.inc.php
@@ -338,6 +348,7 @@
%%WWWDIR%%/instal.php
%%WWWDIR%%/items.php
%%WWWDIR%%/js/class.calendar.js
+%%WWWDIR%%/js/class.cdate.js
%%WWWDIR%%/js/class.cmap.js
%%WWWDIR%%/js/class.cookie.js
%%WWWDIR%%/js/class.cscreen.js
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 83c0dc2c5a06..643abd7e7b53 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zabbix
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.2
PORTREVISION?= 0
PORTEPOCH= 2
CATEGORIES= net-mgmt
@@ -61,7 +61,8 @@ OPTIONS= MYSQL "Use MySQL backend" on \
IPV6 "Support for IPv6" on \
LDAP "Support for checking LDAP servers" on \
JABBER "Use jabber media type" on \
- FPING "Use fping for pinging hosts" on
+ FPING "Use fping for pinging hosts" on \
+ SSH "Use libssh2 for SSH-based checks" off
.include <bsd.port.options.mk>
@@ -75,7 +76,7 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
.elifdef WITH_SQLITE
ZABBIX_REQUIRE=
-USE_SQLITE= yes
+USE_SQLITE= 3
CONFIGURE_ARGS+= --with-sqlite3
.else
IGNORE= zabbix requires a database backend
@@ -94,6 +95,11 @@ CONFIGURE_ARGS+= --with-jabber
.ifndef WITHOUT_FPING
RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
+
+.ifdef WITH_SSH
+LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
+CONFIGURE_ARGS+= --with-ssh2
+.endif
.endif # if ${ZABBIX_BUILD} != "agent"
.ifdef WITH_IPV6
diff --git a/net-mgmt/zabbix2-server/distinfo b/net-mgmt/zabbix2-server/distinfo
index da5e3d690fe6..993d92207709 100644
--- a/net-mgmt/zabbix2-server/distinfo
+++ b/net-mgmt/zabbix2-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (zabbix-1.8.1.tar.gz) = ab1a5006a885d780084bb870320abbc9
-SHA256 (zabbix-1.8.1.tar.gz) = ef487766f22527d79fd7a2631b615c34d04103038341f1dc16eceb77172d8a7c
-SIZE (zabbix-1.8.1.tar.gz) = 3607414
+MD5 (zabbix-1.8.2.tar.gz) = fa4be4fa7ac20a33cc0aa5c27b827746
+SHA256 (zabbix-1.8.2.tar.gz) = ba1d00454551c1c6f0d270f76718b69ce9f54c427e22acb5a13ccbc9e621fd81
+SIZE (zabbix-1.8.2.tar.gz) = 3706540
diff --git a/net-mgmt/zabbix2-server/pkg-plist.frontend b/net-mgmt/zabbix2-server/pkg-plist.frontend
index 621b136ab5df..ce99d0de6175 100644
--- a/net-mgmt/zabbix2-server/pkg-plist.frontend
+++ b/net-mgmt/zabbix2-server/pkg-plist.frontend
@@ -12,6 +12,7 @@
%%WWWDIR%%/api/classes/class.cgraphitem.php
%%WWWDIR%%/api/classes/class.chost.php
%%WWWDIR%%/api/classes/class.chostgroup.php
+%%WWWDIR%%/api/classes/class.cimage.php
%%WWWDIR%%/api/classes/class.citem.php
%%WWWDIR%%/api/classes/class.cmaintenance.php
%%WWWDIR%%/api/classes/class.cmap.php
@@ -54,6 +55,7 @@
%%WWWDIR%%/config.php
%%WWWDIR%%/css.css
%%WWWDIR%%/dashboard.php
+%%WWWDIR%%/dashconf.php
%%WWWDIR%%/discovery.php
%%WWWDIR%%/discoveryconf.php
%%WWWDIR%%/events.php
@@ -90,6 +92,10 @@
%%WWWDIR%%/images/general/bttn/arrowright_bb.png
%%WWWDIR%%/images/general/bttn/arrowup.png
%%WWWDIR%%/images/general/bttn/arrowup_bb.png
+%%WWWDIR%%/images/general/bttn/config.png
+%%WWWDIR%%/images/general/bttn/config_bb.png
+%%WWWDIR%%/images/general/bttn/config_hl.png
+%%WWWDIR%%/images/general/bttn/config_hl_bb.png
%%WWWDIR%%/images/general/bttn/down.png
%%WWWDIR%%/images/general/bttn/down_bb.png
%%WWWDIR%%/images/general/bttn/fullscreen.png
@@ -128,6 +134,7 @@
%%WWWDIR%%/images/general/ipmi_available_bb.png
%%WWWDIR%%/images/general/ipmi_unavailable.png
%%WWWDIR%%/images/general/ipmi_unknown.png
+%%WWWDIR%%/images/general/no_icon.png
%%WWWDIR%%/images/general/ok.png
%%WWWDIR%%/images/general/ok_bb.png
%%WWWDIR%%/images/general/ok_icon.png
@@ -286,6 +293,7 @@
%%WWWDIR%%/include/config.inc.php
%%WWWDIR%%/include/copt.lib.php
%%WWWDIR%%/include/db.inc.php
+%%WWWDIR%%/include/debug.inc.php
%%WWWDIR%%/include/defines.inc.php
%%WWWDIR%%/include/discovery.inc.php
%%WWWDIR%%/include/events.inc.php
@@ -296,6 +304,7 @@
%%WWWDIR%%/include/hosts.inc.php
%%WWWDIR%%/include/html.inc.php
%%WWWDIR%%/include/httptest.inc.php
+%%WWWDIR%%/include/ident.inc.php
%%WWWDIR%%/include/images.inc.php
%%WWWDIR%%/include/items.inc.php
%%WWWDIR%%/include/js.inc.php
@@ -315,6 +324,7 @@
%%WWWDIR%%/include/locales/ru_ru.inc.php
%%WWWDIR%%/include/locales/sp_sp.inc.php
%%WWWDIR%%/include/locales/sv_se.inc.php
+%%WWWDIR%%/include/locales/ua_ua.inc.php
%%WWWDIR%%/include/maintenances.inc.php
%%WWWDIR%%/include/maps.inc.php
%%WWWDIR%%/include/media.inc.php
@@ -338,6 +348,7 @@
%%WWWDIR%%/instal.php
%%WWWDIR%%/items.php
%%WWWDIR%%/js/class.calendar.js
+%%WWWDIR%%/js/class.cdate.js
%%WWWDIR%%/js/class.cmap.js
%%WWWDIR%%/js/class.cookie.js
%%WWWDIR%%/js/class.cscreen.js