aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cflowd/Makefile8
-rw-r--r--net-mgmt/irrtoolset/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/net-mgmt/cflowd/Makefile b/net-mgmt/cflowd/Makefile
index 2c92cef1c2c0..58698a767341 100644
--- a/net-mgmt/cflowd/Makefile
+++ b/net-mgmt/cflowd/Makefile
@@ -22,6 +22,12 @@ COMMENT= Flow analysis tool used for analyzing Cisco's NetFlow switching
BUILD_DEPENDS= ${LOCALBASE}/lib/libArts.a:${PORTSDIR}/net/arts++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@@ -41,4 +47,4 @@ post-install:
${INSTALL_SCRIPT} ${FILESDIR}/cflowd.sh \
${PREFIX}/etc/rc.d/cflowd-base.sh.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/irrtoolset/Makefile b/net-mgmt/irrtoolset/Makefile
index 53bced116452..7cfd192945d8 100644
--- a/net-mgmt/irrtoolset/Makefile
+++ b/net-mgmt/irrtoolset/Makefile
@@ -16,6 +16,12 @@ COMMENT= A suite of routing policy tools to interact with the IRR
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_BISON= yes
USE_GMAKE= yes
USE_GCC= 2.95
@@ -36,4 +42,4 @@ post-patch:
aLL_TARGET= depend all
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>