aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/mtrace/Makefile27
-rw-r--r--net-mgmt/mtrace/distinfo3
-rw-r--r--net-mgmt/mtrace/files/patch-Makefile10
-rw-r--r--net-mgmt/mtrace/files/patch-mtrace.c20
-rw-r--r--net-mgmt/mtrace/pkg-descr2
6 files changed, 63 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 55c6bc90dbe2..6de7a3bfac79 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -82,6 +82,7 @@
SUBDIR += libsmi
SUBDIR += mbrowse
SUBDIR += mrtg
+ SUBDIR += mtrace
SUBDIR += nagcon
SUBDIR += nagios
SUBDIR += nagios-plugins
diff --git a/net-mgmt/mtrace/Makefile b/net-mgmt/mtrace/Makefile
new file mode 100644
index 000000000000..82e627e1e190
--- /dev/null
+++ b/net-mgmt/mtrace/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mtrace
+# Date created: 28 September 2006
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtrace
+PORTVERSION= 5.2
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Multicast traceroute program for IPv4
+
+MAN8= mtrace.8
+
+ALL_TARGET= mtrace
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mtrace ${PREFIX}/sbin/mtrace
+ ${INSTALL_MAN} ${WRKSRC}/mtrace.8 ${PREFIX}/man/man8
+
+PLIST_FILES= sbin/mtrace
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/mtrace/distinfo b/net-mgmt/mtrace/distinfo
new file mode 100644
index 000000000000..46650f357c6a
--- /dev/null
+++ b/net-mgmt/mtrace/distinfo
@@ -0,0 +1,3 @@
+MD5 (mtrace-5.2.tar.gz) = 3d2e3a156205bb4bf62d7dae06d8ab53
+SHA256 (mtrace-5.2.tar.gz) = 36ee82b09000951e55039c683eb493acb01371edcc3a47ddd3465a3ae534403d
+SIZE (mtrace-5.2.tar.gz) = 36488
diff --git a/net-mgmt/mtrace/files/patch-Makefile b/net-mgmt/mtrace/files/patch-Makefile
new file mode 100644
index 000000000000..0fd85016df4c
--- /dev/null
+++ b/net-mgmt/mtrace/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Thu Sep 28 22:57:58 2006
++++ Makefile Thu Sep 28 22:58:46 2006
+@@ -9,6 +9,7 @@
+ #MCAST_INCLUDE= -I/sys
+ #
+ CFLAGS= -O ${MCAST_INCLUDE} ## SunOS, OSF1, FreeBSD, IRIX
++CFLAGS+= -O2 -fno-strict-aliasing -Dlog=logit
+ #CFLAGS= -O ${MCAST_INCLUDE} -DRAW_OUTPUT_IS_RAW ## OpenBSD
+ #CFLAGS= -O ${MCAST_INCLUDE} -D__BSD_SOURCE -DRAW_OUTPUT_IS_RAW -DRAW_INPUT_IS_RAW ## Linux
+ #CFLAGS= -O ${MCAST_INCLUDE} -DSYSV -DSUNOS5 ## Solaris 2.x
diff --git a/net-mgmt/mtrace/files/patch-mtrace.c b/net-mgmt/mtrace/files/patch-mtrace.c
new file mode 100644
index 000000000000..ee0f4d7b2c57
--- /dev/null
+++ b/net-mgmt/mtrace/files/patch-mtrace.c
@@ -0,0 +1,20 @@
+--- mtrace.c.orig Thu Sep 28 22:58:53 2006
++++ mtrace.c Thu Sep 28 23:00:11 2006
+@@ -1486,6 +1486,7 @@
+ struct sockaddr_in recvaddr;
+ struct tm *now;
+ char timebuf[32];
++ time_t tr_sec;
+ int socklen;
+ int ipdatalen, iphdrlen, igmpdatalen;
+ int len, recvlen;
+@@ -1593,7 +1594,8 @@
+ }
+ }
+
+- now = localtime(&tr.tv_sec);
++ tr_sec = tr.tv_sec;
++ now = localtime(&tr_sec);
+ strftime(timebuf, sizeof(timebuf) - 1, "%b %e %k:%M:%S", now);
+ printf("Mtrace %s at %s",
+ len == 0 ? "query" :
diff --git a/net-mgmt/mtrace/pkg-descr b/net-mgmt/mtrace/pkg-descr
new file mode 100644
index 000000000000..5ba5744be18e
--- /dev/null
+++ b/net-mgmt/mtrace/pkg-descr
@@ -0,0 +1,2 @@
+mtrace is a program to trace the routes taken by IPv4 multicast
+traffic flows.