aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ap-utils/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
index 20285750cde3..e1ba45352cde 100644
--- a/net-mgmt/ap-utils/Makefile
+++ b/net-mgmt/ap-utils/Makefile
@@ -17,7 +17,10 @@ COMMENT= A set of utilities to configure and monitor wireless access points
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_BZIP2= yes
-CONFIGURE_ENV= LDFLAGS="-lintl -L${LOCALBASE}/lib"
+USE_ICONV= yes
+CONFIGURE_ENV= LDFLAGS="-lintl -L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
MAN8= ap-trapd.8 ap-mrtg.8 ap-config.8
.if !defined(WITHOUT_NLS)
@@ -29,12 +32,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|_nl_domain_bindings|libintl_nl_domain_bindings|' ${WRKSRC}/configure
@@ -45,4 +42,4 @@ post-install:
${INSTALL_DATA} FAQ Ovislink-HOWTO.html HARDWARE-NOTES README.ap-gl ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>