aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix2-server/Makefile8
-rw-r--r--net-mgmt/zabbix22-server/Makefile7
-rw-r--r--net-mgmt/zabbix3-server/Makefile6
-rw-r--r--net-mgmt/zabbix32-server/Makefile7
-rw-r--r--net-mgmt/zabbix34-server/Makefile6
5 files changed, 24 insertions, 10 deletions
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 4d95b50305d6..8e37a8b75f10 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zabbix2
PORTVERSION= 2.0.20
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
@@ -125,7 +125,11 @@ JAVAGW_USE= JAVA=yes
post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
- @${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' ${WRKSRC}/conf/zabbix_*.conf
+ @${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' \
+ ${WRKSRC}/conf/zabbix_*.conf \
+ ${WRKSRC}/src/zabbix_proxy/proxy.c \
+ ${WRKSRC}/src/zabbix_server/server.c
+
.if ${ZABBIX_BUILD} != "agent"
.for d in mysql oracle postgresql sqlite3
diff --git a/net-mgmt/zabbix22-server/Makefile b/net-mgmt/zabbix22-server/Makefile
index d7e54f76e8e9..53a47b9c2b07 100644
--- a/net-mgmt/zabbix22-server/Makefile
+++ b/net-mgmt/zabbix22-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zabbix22
PORTVERSION= 2.2.21
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
@@ -130,7 +130,10 @@ LIBXML2_LIB_DEPENDS= libxml2.so:textproc/libxml2
post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
- @${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' ${WRKSRC}/conf/zabbix_*.conf
+ @${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' \
+ ${WRKSRC}/conf/zabbix_*.conf \
+ ${WRKSRC}/src/zabbix_proxy/proxy.c \
+ ${WRKSRC}/src/zabbix_server/server.c
.if ${ZABBIX_BUILD} != "agent"
.if ! ${PORT_OPTIONS:MFPING}
diff --git a/net-mgmt/zabbix3-server/Makefile b/net-mgmt/zabbix3-server/Makefile
index 354463c29d5a..4a98c78777bf 100644
--- a/net-mgmt/zabbix3-server/Makefile
+++ b/net-mgmt/zabbix3-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zabbix3
PORTVERSION= 3.0.14
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
@@ -152,7 +152,9 @@ post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
@${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' \
- ${WRKSRC}/conf/zabbix_*.conf
+ ${WRKSRC}/conf/zabbix_*.conf \
+ ${WRKSRC}/src/zabbix_proxy/proxy.c \
+ ${WRKSRC}/src/zabbix_server/server.c
.if ${ZABBIX_BUILD} == "server"
@${REINPLACE_CMD} -e 's#PidFile=/tmp/zabbix_server.pid#PidFile=/var/run/zabbix/zabbix_server.pid#g' \
diff --git a/net-mgmt/zabbix32-server/Makefile b/net-mgmt/zabbix32-server/Makefile
index ca329d398dbc..8c39db7c5276 100644
--- a/net-mgmt/zabbix32-server/Makefile
+++ b/net-mgmt/zabbix32-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zabbix32
PORTVERSION= 3.2.11
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
@@ -154,7 +154,10 @@ post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
@${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' \
- ${WRKSRC}/conf/zabbix_*.conf
+ ${WRKSRC}/conf/zabbix_*.conf \
+ ${WRKSRC}/src/zabbix_proxy/proxy.c \
+ ${WRKSRC}/src/zabbix_server/server.c
+
.if ${ZABBIX_BUILD} == "server"
@${REINPLACE_CMD} -e 's#PidFile=/tmp/zabbix_server.pid#PidFile=/var/run/zabbix/zabbix_server.pid#g' \
diff --git a/net-mgmt/zabbix34-server/Makefile b/net-mgmt/zabbix34-server/Makefile
index 913064a8e555..29ebe5244436 100644
--- a/net-mgmt/zabbix34-server/Makefile
+++ b/net-mgmt/zabbix34-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zabbix34
PORTVERSION= 3.4.7
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
@@ -157,7 +157,9 @@ post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
| ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
@${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' \
- ${WRKSRC}/conf/zabbix_*.conf
+ ${WRKSRC}/conf/zabbix_*.conf \
+ ${WRKSRC}/src/zabbix_proxy/proxy.c \
+ ${WRKSRC}/src/zabbix_server/server.c
.if ${ZABBIX_BUILD} == "server"
@${REINPLACE_CMD} -e 's#PidFile=/tmp/zabbix_server.pid#PidFile=/var/run/zabbix/zabbix_server.pid#g' \