aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/alertmanager/Makefile4
-rw-r--r--net-mgmt/prometheus2/Makefile2
-rw-r--r--net-mgmt/pushgateway/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/net-mgmt/alertmanager/Makefile b/net-mgmt/alertmanager/Makefile
index ab84585a7db7..486ef8d5b8a2 100644
--- a/net-mgmt/alertmanager/Makefile
+++ b/net-mgmt/alertmanager/Makefile
@@ -23,8 +23,8 @@ USERS= alertmanager
GROUPS= alertmanager
do-build:
- @cd ${GO_WRKSRC}/cmd/alertmanager && ${SETENV} ${GO_ENV} go install
- @cd ${GO_WRKSRC}/cmd/amtool && ${SETENV} ${GO_ENV} go install
+ @cd ${GO_WRKSRC}/cmd/alertmanager && ${SETENV} ${MAKE_ENV} ${GO_ENV} go install
+ @cd ${GO_WRKSRC}/cmd/amtool && ${SETENV} ${MAKE_ENV} ${GO_ENV} go install
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/alertmanager ${STAGEDIR}${PREFIX}/bin
diff --git a/net-mgmt/prometheus2/Makefile b/net-mgmt/prometheus2/Makefile
index 044eaf324cda..a749cf7f4ace 100644
--- a/net-mgmt/prometheus2/Makefile
+++ b/net-mgmt/prometheus2/Makefile
@@ -36,7 +36,7 @@ PROMETHEUS_BINARIES= prometheus promtool
do-build:
.for bin in ${PROMETHEUS_BINARIES}
( cd ${GO_WRKSRC}/cmd/${bin} ; \
- ${SETENV} ${GO_ENV} go install -ldflags "${LD_FLAG_STRING}" )
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} go install -ldflags "${LD_FLAG_STRING}" )
.endfor
do-install:
diff --git a/net-mgmt/pushgateway/Makefile b/net-mgmt/pushgateway/Makefile
index d2159bb396e3..3e8142151e3f 100644
--- a/net-mgmt/pushgateway/Makefile
+++ b/net-mgmt/pushgateway/Makefile
@@ -24,7 +24,7 @@ USERS= prometheus
GROUPS= prometheus
do-build:
- (cd ${GO_WRKSRC} ; ${SETENV} ${GO_ENV} go install)
+ @(cd ${GO_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GO_ENV} go install)
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/pushgateway ${STAGEDIR}${PREFIX}/bin