aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/argus3-clients/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-mgmt/argus3-clients/Makefile b/net-mgmt/argus3-clients/Makefile
index 6380868115ac..cbedc960844d 100644
--- a/net-mgmt/argus3-clients/Makefile
+++ b/net-mgmt/argus3-clients/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= http://qosient.com/argus/src/ \
MAINTAINER= se@freebsd.org
COMMENT= Client programs for the argus IP network transaction auditing tool
-OPTIONS+= SASL "SASL authentication support 1" on
+OPTIONS+= SASL "SASL authentication support 1" on \
+ DEBUG "Enable debug" off
.include <bsd.port.pre.mk>
@@ -27,7 +28,7 @@ USE_BISON= build
GNU_CONFIGURE= true
.if defined(WITH_SASL)
-CONFIGURE_ARGS+= --with-sasl=${PREFIX}
+CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
MAN1= ra.1 rabins.1 racluster.1 racount.1 ragraph.1 ragrep.1 rahisto.1 \
@@ -35,6 +36,11 @@ MAN1= ra.1 rabins.1 racluster.1 racount.1 ragraph.1 ragrep.1 rahisto.1 \
MAN5= racluster.5 radium.conf.5 rarc.5
MAN8= radium.8
+pre-configure:
+.if defined(WITH_DEBUG)
+ ${TOUCH} ${WRKSRC}/.debug
+.endif
+
do-install:
.for i in ra rabins racluster racount radump rafilteraddr \
ragrep rahisto ralabel ranonymize rapath rapolicy \