aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gift/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gift/Makefile')
-rw-r--r--net-p2p/gift/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-p2p/gift/Makefile b/net-p2p/gift/Makefile
new file mode 100644
index 000000000000..37855fe240d9
--- /dev/null
+++ b/net-p2p/gift/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: giFT library
+# Date created: Fri Nov 16 02:47:45 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFT
+PORTVERSION= 0.11.4
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
+DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+
+MAINTAINER= Stefan Ehmann <shoesoft@gmx.net>
+COMMENT= An OpenFT, Gnutella and FastTrack p2p network client
+
+LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl \
+ vorbis.2:${PORTSDIR}/audio/libvorbis \
+ Magick.5:${PORTSDIR}/graphics/ImageMagick
+.if defined(WITH_LIBMAGIC)
+LIB_DEPENDS+= magic.1:${PORTSDIR}/sysutils/file
+.endif
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+.if defined(WITH_LIBMAGIC)
+CONFIGURE_ARGS= --enable-libmagic
+.endif
+
+MAN1= giftd.1
+
+DOC_FILES= AUTHORS COPYING ChangeLog \
+ INSTALL NEWS QUICKSTART README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/lib/Makefile.in
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>