aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/libtorrent-rasterbar-python/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/libtorrent-rasterbar-python/Makefile')
-rw-r--r--net-p2p/libtorrent-rasterbar-python/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/net-p2p/libtorrent-rasterbar-python/Makefile b/net-p2p/libtorrent-rasterbar-python/Makefile
index a2ac28b24083..5a46e2a27274 100644
--- a/net-p2p/libtorrent-rasterbar-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-python/Makefile
@@ -1,31 +1,28 @@
# Created by: Doug Barton <dougb@FreeBSD.org>
# $FreeBSD$
-CATEGORIES= net-p2p python
+PORTNAME= libtorrent-rasterbar
+DISTVERSION= 1.1.10
+CATEGORIES= net-p2p ipv6 python
+MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+MAINTAINER= yuri@FreeBSD.org
COMMENT= Python bindings for libtorrent-rasterbar
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../../COPYING
+
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
${PY_BOOST}
-MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar
-
-BUILD_WRKSRC= ${WRKSRC}/bindings/python
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-SLAVE_PORT= yes
-USES= python:2.7
-USE_PYTHON= distutils
-PYDISTUTILS_PKGNAME= python_libtorrent
-
-PLIST= ${NONEXISTENT}
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/libtorrent.so
+USES= localbase python:2.7
+USE_PYTHON= distutils autoplist
-OPTIONS_EXCLUDE= DOCS EXAMPLES
+WRKSRC_SUBDIR= bindings/python
# ensure python paths are correctly identified
CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
PYTHON_VERSION="${PYTHON_VERSION}"
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>