aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/litecoin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/litecoin/Makefile')
-rw-r--r--net-p2p/litecoin/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index f2ebe156d526..26bb0cc4ca04 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -92,6 +92,13 @@ LDFLAGS+= -L${OPENSSLLIB}
PLIST_FILES?= bin/litecoin-qt share/applications/litecoin-qt.desktop \
share/pixmaps/litecoin128.png
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mlibressl*}
+# The configure script will output this message, so save the user the trouble
+IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+.endif
+
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
post-patch:
@@ -115,4 +122,4 @@ regression-test: build
@cd ${WRKSRC} && ${GMAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>