aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/mldonkey-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mldonkey-gui/Makefile')
-rw-r--r--net-p2p/mldonkey-gui/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/net-p2p/mldonkey-gui/Makefile b/net-p2p/mldonkey-gui/Makefile
index d7327418d5e2..c7fa0bd0a68e 100644
--- a/net-p2p/mldonkey-gui/Makefile
+++ b/net-p2p/mldonkey-gui/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= mldonkey
-PORTVERSION= 2.02.0
+PORTVERSION= 2.04.r1
CATEGORIES= net
-MASTER_SITES= http://ernie.eit.uni-kl.de/mldonkey/ \
- http://savannah.nongnu.org/download/mldonkey/stable/contributed/
+MASTER_SITES= http://savannah.nongnu.org/download/mldonkey/release-2.04rc1/contributed/holger/
PKGNAMESUFFIX= -gui
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/.0$/-0/}.shared.${ARCH}-${OPSYS}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}-0.shared.${ARCH}-${OPSYS}-hl
MAINTAINER= holger@e-gitt.net
COMMENT= A OCAML/GTK GUI for the mldonkey peer-to-peer network client
@@ -21,16 +20,29 @@ USE_BZIP2= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-distrib-${PORTVERSION:C/.(.)$/-\1/}
+WRKSRC= ${WRKDIR}/${PORTNAME}-distrib-${PORTVERSION:S/.r/rc/}-0
DIRNAME= ${HOME}/.mldonkey
+post-patch:
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper.sh
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey+gui ${PREFIX}/bin/mldonkey+gui-real
+ @if [ -e ${PREFIX}/bin/mldonkey ]; then \
+ ${LN} ${PREFIX}/bin/mldonkey ${PREFIX}/bin/mldonkey+gui; \
+ else \
+ ${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey+gui; \
+ fi
@${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui2 ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/mldonkey_previewer ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_guistarter ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mlim ${PREFIX}/bin
post-install:
- @${FMT} < ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
@@ -41,7 +53,7 @@ LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
install-user: extract
.if !defined(LANG)
@${ECHO_MSG} "Please call as: make install-user LANG=<lang>"
- @${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents !"
+ @${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents,sp !"
.else
@${CP} ${WRKSRC}/i18n/gui_messages.ini.${LANG}\
${HOME}/.mldonkey_gui_messages.ini