aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/mldonkey
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mldonkey')
-rw-r--r--net-p2p/mldonkey/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 5f516d873f96..0f9e59b82f97 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -37,6 +37,8 @@ CONFIGURE_ENV+= \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+# FreeBSD has reentrant dns code
+PTHREAD_CFLAGS+= -D_REENTRANT
###
## Library dependency handling
@@ -109,11 +111,6 @@ ALL_TARGET+= \
.include <bsd.port.pre.mk>
-# FreeBSD has reentrant dns code
-.if ( ((${OSVERSION} >= 504102) && (${OSVERSION} < 600000)) || (${OSVERSION} >= 600029) )
-PTHREAD_CFLAGS+= -D_REENTRANT
-.endif
-
### Development version
## Thus, we will use non standard threading library
## We will switch from libpthread to libthr which should produce