aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/retroshare/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/retroshare/Makefile')
-rw-r--r--net-p2p/retroshare/Makefile53
1 files changed, 33 insertions, 20 deletions
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 18c8e5eb49c6..ab01a8014c8d 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -1,30 +1,39 @@
-# New ports collection makefile for: retroshare
-# Date created: 15 January 2012
-# Whom: glocke
-#
+# Created by: glocke@bsdstammtisch.at
# $FreeBSD$
-#
PORTNAME= retroshare
-PORTVERSION= 0.5.3a
-PORTREVISION= 2
+PORTVERSION= 0.5.4b
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}/${BINARY}/${PORTVERSION}
DISTNAME= ${BINARY}-v${PORTVERSION}
-MAINTAINER= glocke@bsdstammtisch.at
-COMMENT= A private and secure decentralised communication platform
+MAINTAINER= peter@netkey.at
+COMMENT= Private and secure decentralised communication platform
LICENSE= GPLv2
-LICENSE_FILE= ${WRKDIR}/trunk/retroshare-gui/src/license/license.txt
-LIB_DEPENDS= gpgme.19:${PORTSDIR}/security/gpgme \
- upnp.9:${PORTSDIR}/devel/upnp \
- gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ upnp:${PORTSDIR}/devel/upnp \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ assuan:${PORTSDIR}/security/libassuan \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ gnome-keyring:${PORTSDIR}/security/libgnome-keyring \
+ gpg-error:${PORTSDIR}/security/libgpg-error \
+ gpgme:${PORTSDIR}/security/gpgme \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS+= pinentry-qt4:${PORTSDIR}/security/pinentry-qt4
WRKSRC= ${WRKDIR}/trunk
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_GNOME= glib20
+USE_XORG= ice sm x11 xau xdmcp xext xrender
USE_QT4= corelib gui network xml script designer_build uic_build \
qmake_build moc_build rcc_build
HAS_CONFIGURE= yes
@@ -35,7 +44,8 @@ MAKE_JOBS_UNSAFE=yes
DESKTOP_ENTRIES="${BINARY}" "${COMMENT}" "" "${BINARY}" \
"Network;FileTransfer;" true
-OPTIONS= NOGUI "Also build nogui binary" Off
+OPTIONS_DEFINE= NOGUI
+NOGUI_DESC= "Install retroshare-nogui binary"
.include <bsd.port.options.mk>
@@ -43,28 +53,31 @@ do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} PREFIX=${PREFIX} ${BINARY}.pro
+USE_DOS2UNIX= retroshare-gui/src/retroshare-gui.pro \
+ retroshare-nogui/src/retroshare-nogui.pro
+
post-patch:
- @${REINPLACE_CMD} -e 's|plugins|#plugins|' ${WRKSRC}/${BINARY}.pro
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/libretroshare/src/libretroshare.pro
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/retroshare-gui/src/RetroShare.pro
+ ${WRKSRC}/retroshare-gui/src/retroshare-gui.pro
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/retroshare-nogui/src/retroshare-nogui.pro
@${REINPLACE_CMD} -e 's|/usr/local/share/retroshare|${DATADIR}|' \
${WRKSRC}/libretroshare/src/rsserver/rsinit.cc
-.if defined(WITHOUT_NOGUI)
+.if empty(PORT_OPTIONS:MNOGUI)
@${REINPLACE_CMD} -e 's|retroshare-nogui|#retroshare-nogui|' \
${WRKSRC}/${BINARY}.pro
- @${REINPLACE_CMD} -e 's|RetroShare.pro \\|RetroShare.pro|' \
+ @${REINPLACE_CMD} -e 's|retroshare-gui.pro \\|retroshare-gui.pro|' \
${WRKSRC}/${BINARY}.pro
.else
@${REINPLACE_CMD} -e 's|retroshare-nogui.pro \\|retroshare-nogui.pro|' \
${WRKSRC}/${BINARY}.pro
.endif
+ @${REINPLACE_CMD} -e 's|plugins|#plugins|' ${WRKSRC}/${BINARY}.pro
pre-install:
-.if defined(WITHOUT_NOGUI)
+.if empty(PORT_OPTIONS:MNOGUI)
PLIST_SUB+= NOGUI="@comment "
.else
PLIST_SUB+= NOGUI=""
@@ -72,7 +85,7 @@ PLIST_SUB+= NOGUI=""
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/retroshare-gui/src/${BINARY} ${PREFIX}/bin
-.if defined(WITH_NOGUI)
+.if ${PORT_OPTIONS:MNOGUI}
${INSTALL_PROGRAM} ${WRKSRC}/retroshare-nogui/src/${BINARY_NOGUI} ${PREFIX}/bin
.endif
${MKDIR} ${DATADIR}