aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/rtorrent-devel
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rtorrent-devel')
-rw-r--r--net-p2p/rtorrent-devel/Makefile8
-rw-r--r--net-p2p/rtorrent-devel/distinfo4
-rw-r--r--net-p2p/rtorrent-devel/files/patch-src__display__canvas.h11
3 files changed, 5 insertions, 18 deletions
diff --git a/net-p2p/rtorrent-devel/Makefile b/net-p2p/rtorrent-devel/Makefile
index a095d3e7b65d..58fef8ca1835 100644
--- a/net-p2p/rtorrent-devel/Makefile
+++ b/net-p2p/rtorrent-devel/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= rtorrent-devel
-PORTVERSION= 0.8.7
+PORTVERSION= 0.8.8
PORTREVISION= 0
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= flz@FreeBSD.org
COMMENT= BitTorrent Client written in C++ (development version)
-BUILD_DEPENDS= libtorrent-devel=0.12.7:${PORTSDIR}/net-p2p/libtorrent-devel
-RUN_DEPENDS= libtorrent-devel=0.12.7:${PORTSDIR}/net-p2p/libtorrent-devel
+BUILD_DEPENDS= libtorrent-devel=0.12.8:${PORTSDIR}/net-p2p/libtorrent-devel
+RUN_DEPENDS= libtorrent-devel=0.12.8:${PORTSDIR}/net-p2p/libtorrent-devel
BROKEN= fails to package
@@ -26,8 +26,6 @@ DESCR= ${MASTERDIR}/pkg-descr
CONFLICTS= rtorrent-[0-9]*
-MAN1= rtorrent.1
-
USE_GCC= 4.2+
.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/rtorrent-devel/distinfo b/net-p2p/rtorrent-devel/distinfo
index ed3ea8ed47cf..ce9a2acde6db 100644
--- a/net-p2p/rtorrent-devel/distinfo
+++ b/net-p2p/rtorrent-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rtorrent-0.8.7.tar.gz) = 1fd0c9b2b3fe81b035209417c4dd4514473411f16b15ffe7fefe87eaff1a58d2
-SIZE (rtorrent-0.8.7.tar.gz) = 547435
+SHA256 (rtorrent-0.8.8.tar.gz) = 8511eac924a49ae577806191c2f3a590661a1e946f3a5ecaca477e054a75ec62
+SIZE (rtorrent-0.8.8.tar.gz) = 568704
diff --git a/net-p2p/rtorrent-devel/files/patch-src__display__canvas.h b/net-p2p/rtorrent-devel/files/patch-src__display__canvas.h
deleted file mode 100644
index 583ef1828aed..000000000000
--- a/net-p2p/rtorrent-devel/files/patch-src__display__canvas.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/display/canvas.h.orig 2010-06-26 14:05:07.000000000 +0200
-+++ src/display/canvas.h 2011-04-09 11:21:30.000000000 +0200
-@@ -48,7 +48,7 @@
- public:
- typedef std::vector<Attributes> attributes_list;
-
-- Canvas(int x = 0, int y = 0, int width = 0, int height = 0) :
-+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1) :
- m_window(newwin(height, width, y, x)) {}
- ~Canvas() { delwin(m_window); }
-