aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/vuze/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/vuze/Makefile')
-rw-r--r--net-p2p/vuze/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index 7dfbbbb2f44b..1dba74e41d85 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= azureus
-PORTVERSION= 3.0.1.6
+PORTVERSION= 3.0.3.0
CATEGORIES= net-p2p java
MASTER_SITES= SF
DISTNAME= Azureus_${PORTVERSION}_source
@@ -33,7 +33,8 @@ NO_WRKSUBDIR= yes
JARFILE= ${PORTNAME}.jar
-OPTIONS= SWTDEVEL "Use SWT Development port" on
+OPTIONS= SWTDEVEL "Use SWT Development port" on \
+ EXTRAHACK "Apply extra performance hack" off
# build classpath from BUILD_DEPENDS
MAKE_ENV= LANG=C
@@ -52,7 +53,13 @@ SUB_LIST= LIBDIR="${LOCALBASE}/lib" JARFILE="${JARFILE}" \
SWT= swt-devel
.else
SWT= swt
-BROKEN= swt-devel is currently required
+.endif
+
+# Ok, I'm not quite sure why this works, or if it is in any way a proper fix.
+# Use at your own risk, I've just had it around and decided to share.
+.if defined(WITH_EXTRAHACK)
+EXTRA_PATCHES+= \
+ ${PATCHDIR}/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterStream.java
.endif
CLASSPATH=.