aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-cli/Makefile4
-rw-r--r--net-p2p/tribler/Makefile8
-rw-r--r--net-p2p/unworkable/Makefile3
3 files changed, 8 insertions, 7 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 255c8bc2b757..6d7ddb5322a7 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -2,7 +2,7 @@
PORTNAME= transmission
PORTVERSION= 2.84
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net-p2p
#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
MASTER_SITES= http://transmission.cachefly.net/
@@ -34,7 +34,7 @@ LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
# General dependencies
GEN_LIB_DEPENDS=libcurl.so:${PORTSDIR}/ftp/curl \
- libevent-2.0.so.6:${PORTSDIR}/devel/libevent2
+ libevent.so:${PORTSDIR}/devel/libevent2
GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
# This is master port of transmission-*, so don't override USES definition
diff --git a/net-p2p/tribler/Makefile b/net-p2p/tribler/Makefile
index b493dfbd93df..222cf7dca3d7 100644
--- a/net-p2p/tribler/Makefile
+++ b/net-p2p/tribler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tribler
PORTVERSION= 6.0.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-p2p
#MASTER_SITES= http://dl.tribler.org/
MASTER_SITES= GENTOO/distfiles \
@@ -20,7 +20,7 @@ LICENSE= LGPL21 MIT
LICENSE_COMB= multi
EXTRACT_DEPENDS=${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2 \
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2 \
libvlc.so:${PORTSDIR}/multimedia/vlc
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}netifaces>0:${PORTSDIR}/net/py-netifaces \
@@ -65,9 +65,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O2|| ; \
s|CPPFLAGS|CXXFLAGS| ; \
s|-g -I$${LIBEVENT_HOME}/include|-I$${LOCALBASE}/include| ; \
- s|-levent -lstdc++|-levent-2.0| ; \
+ s|-lstdc++|| ; \
s|g++|$${CXX}| ; \
- s|$${LIBEVENT_HOME}/lib|$${LOCALBASE}/lib/event2|g' \
+ s|$${LIBEVENT_HOME}/lib|$${LOCALBASE}/lib|g' \
${WRKDIR}/usr/share/tribler/Tribler/SwiftEngine/Makefile
@${REINPLACE_CMD} 's|linux|freebsd|' \
${WRKDIR}/usr/share/tribler/Tribler/vlc.py
diff --git a/net-p2p/unworkable/Makefile b/net-p2p/unworkable/Makefile
index e12ee0be57b4..16aa576bb104 100644
--- a/net-p2p/unworkable/Makefile
+++ b/net-p2p/unworkable/Makefile
@@ -3,13 +3,14 @@
PORTNAME= unworkable
PORTVERSION= 0.53
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
MAINTAINER= wenheping@gmail.com
COMMENT= Free BitTorrent Implementation
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
USES= scons
USE_OPENSSL= yes