aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dclib/Makefile2
-rw-r--r--net-p2p/gnunet/Makefile2
-rw-r--r--net-p2p/libfreenet/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index d63165c7d8c2..43cf8c8d3197 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
post-patch:
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 7ee8e1db3ab5..f890043693c5 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -28,7 +28,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnometarget gtk20 lthack
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --disable-ltdl-install --with-crypto
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net-p2p/libfreenet/Makefile b/net-p2p/libfreenet/Makefile
index 4459b7dfec7d..75d358c27115 100644
--- a/net-p2p/libfreenet/Makefile
+++ b/net-p2p/libfreenet/Makefile
@@ -19,7 +19,7 @@ USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/libfreenet
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \