aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge-cli/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar-python/Makefile27
-rw-r--r--net-p2p/libtorrent-rasterbar-python/distinfo3
-rw-r--r--net-p2p/libtorrent-rasterbar-python/files/patch-setup.py17
-rw-r--r--net-p2p/libtorrent-rasterbar-python/pkg-descr4
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile53
-rw-r--r--net-p2p/libtorrent-rasterbar/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt10
-rw-r--r--net-p2p/libtorrent-rasterbar/pkg-plist10
-rw-r--r--net-p2p/qbittorrent/Makefile1
-rw-r--r--net-p2p/tribler/Makefile2
11 files changed, 67 insertions, 68 deletions
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
index f103bb6c97f1..8f19b6cb4a95 100644
--- a/net-p2p/deluge-cli/Makefile
+++ b/net-p2p/deluge-cli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= deluge
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 1.3.15
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-p2p python
PKGNAMESUFFIX= -cli
diff --git a/net-p2p/libtorrent-rasterbar-python/Makefile b/net-p2p/libtorrent-rasterbar-python/Makefile
index a2ac28b24083..5a46e2a27274 100644
--- a/net-p2p/libtorrent-rasterbar-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-python/Makefile
@@ -1,31 +1,28 @@
# Created by: Doug Barton <dougb@FreeBSD.org>
# $FreeBSD$
-CATEGORIES= net-p2p python
+PORTNAME= libtorrent-rasterbar
+DISTVERSION= 1.1.10
+CATEGORIES= net-p2p ipv6 python
+MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+MAINTAINER= yuri@FreeBSD.org
COMMENT= Python bindings for libtorrent-rasterbar
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../../COPYING
+
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
${PY_BOOST}
-MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar
-
-BUILD_WRKSRC= ${WRKSRC}/bindings/python
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-SLAVE_PORT= yes
-USES= python:2.7
-USE_PYTHON= distutils
-PYDISTUTILS_PKGNAME= python_libtorrent
-
-PLIST= ${NONEXISTENT}
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/libtorrent.so
+USES= localbase python:2.7
+USE_PYTHON= distutils autoplist
-OPTIONS_EXCLUDE= DOCS EXAMPLES
+WRKSRC_SUBDIR= bindings/python
# ensure python paths are correctly identified
CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
PYTHON_VERSION="${PYTHON_VERSION}"
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/net-p2p/libtorrent-rasterbar-python/distinfo b/net-p2p/libtorrent-rasterbar-python/distinfo
new file mode 100644
index 000000000000..2bb772897d2a
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538852302
+SHA256 (libtorrent-rasterbar-1.1.10.tar.gz) = 07b2b391e0d16bc693d793e352338488a0e41f3130b70884bb2e0270ea00b8c2
+SIZE (libtorrent-rasterbar-1.1.10.tar.gz) = 3902542
diff --git a/net-p2p/libtorrent-rasterbar-python/files/patch-setup.py b/net-p2p/libtorrent-rasterbar-python/files/patch-setup.py
new file mode 100644
index 000000000000..d7365e7de3e1
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-python/files/patch-setup.py
@@ -0,0 +1,17 @@
+--- setup.py.orig 2018-10-06 18:51:57 UTC
++++ setup.py
+@@ -131,11 +131,11 @@ else:
+ source_list = os.listdir(os.path.join(os.path.dirname(__file__), "src"))
+ source_list = [os.path.abspath(os.path.join(os.path.dirname(__file__), "src", s)) for s in source_list if s.endswith(".cpp")]
+
+- if extra_cmd:
++ if True or extra_cmd:
+ flags = flags_parser()
+ # ldflags must be parsed first to ensure the correct library search path order
+- extra_link = flags.parse(ldflags)
+- extra_compile = flags.parse(extra_cmd)
++ extra_link = flags.parse(os.environ['LDFLAGS'])
++ extra_compile = flags.parse(os.environ['CFLAGS'])
+
+ # for some reason distutils uses the CC environment variable to determine
+ # the compiler to use for C++
diff --git a/net-p2p/libtorrent-rasterbar-python/pkg-descr b/net-p2p/libtorrent-rasterbar-python/pkg-descr
new file mode 100644
index 000000000000..9d6a02d83644
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-python/pkg-descr
@@ -0,0 +1,4 @@
+The python vinfing of libtorrent, an open source C++ library implementing the
+BitTorrent protocol.
+
+WWW: http://libtorrent.org/
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 40e4e48bc54f..75a47a49e3f6 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -2,35 +2,24 @@
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
-DISTVERSION= 1.1.9
-CATEGORIES?= net-p2p ipv6
+DISTVERSION= 1.1.10
+CATEGORIES= net-p2p ipv6
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
MAINTAINER= yuri@FreeBSD.org
-COMMENT?= C++ library implementing a BitTorrent client
+COMMENT= C++ library implementing a BitTorrent client
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= fails to build: client_test.cpp: undefined reference to std::__cxx11::basic_string
-LIB_DEPENDS+= libboost_chrono.so:devel/boost-libs \
+LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
-USES+= compiler:c++11-lib iconv:wchar_t libtool pathfix pkgconfig ssl
-USE_CXXSTD= c++11
-GNU_CONFIGURE= yes
+USES= cmake:outsource compiler:c++14-lang iconv:wchar_t libtool pathfix pkgconfig ssl
USE_LDCONFIG= yes
-TEST_TARGET= check
-
-CONFIGURE_ARGS= --disable-static \
- --enable-dht \
- --enable-encryption \
- --enable-pool-allocators \
- --enable-deprecated-functions \
- --with-boost=${LOCALBASE} \
- --with-libiconv \
- --with-openssl=${OPENSSLBASE}
SHLIB_VER= 9
PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
@@ -39,7 +28,7 @@ DOCFILES= AUTHORS ChangeLog
PORTDOCS= ${DOCFILES} docs/*
PORTEXAMPLES= *.cpp
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LOGGING TEST
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LOGGING
OPTIONS_DEFAULT=LOGGING
OPTIONS_SUB= yes
LOGGING_DESC= Enable disk stat logging and logging to disk
@@ -47,36 +36,18 @@ LOGGING_DESC= Enable disk stat logging and logging to disk
DEBUG_CONFIGURE_ENABLE= debug
EXAMPLES_CONFIGURE_ENABLE= examples
LOGGING_CONFIGURE_ENABLE= logging disk-stats
-TEST_CONFIGURE_ENABLE= tests
-
-.include <bsd.port.options.mk>
-
-.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "yes" && defined(USE_PYTHON)
-CONFIGURE_ARGS+= --enable-python-binding
-.else
-CONFIGURE_ARGS+= --disable-python-binding
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/include|${PREFIX}/include|' \
${WRKSRC}/Jamfile
-post-configure:
- ${FIND} ${WRKSRC} -name Makefile -o -name link_flags | \
- ${XARGS} ${REINPLACE_CMD} 's| *-R${LOCALBASE}/lib||'
-
post-install:
-.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "yes" && defined(USE_PYTHON)
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libtorrent.so
-.else
- ${STRIP_CMD} \
- ${STAGEDIR}${PREFIX}/lib/libtorrent-rasterbar.so.${SHLIB_VER}
-.endif
+ @${RM} ${STAGEDIR}${PREFIX}/include/libtorrent/tommath.h.orig ${STAGEDIR}${PREFIX}/include/libtorrent/Makefile*
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR})
+ cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR}
${RM} ${STAGEDIR}${DOCSDIR}/docs/._*
post-install-EXAMPLES-on:
@@ -84,4 +55,10 @@ post-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/examples/${PORTEXAMPLES} \
${STAGEDIR}${EXAMPLESDIR}
+do-test: # broken: https://github.com/arvidn/libtorrent/issues/3327
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dbuild_tests=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
.include <bsd.port.mk>
diff --git a/net-p2p/libtorrent-rasterbar/distinfo b/net-p2p/libtorrent-rasterbar/distinfo
index 4dd25594ccd1..f10367fe9917 100644
--- a/net-p2p/libtorrent-rasterbar/distinfo
+++ b/net-p2p/libtorrent-rasterbar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534791500
-SHA256 (libtorrent-rasterbar-1.1.9.tar.gz) = d57a0f5b159f58003c3031943463503f0d05ae3e428dd7c2383d1e35fb2c4e8c
-SIZE (libtorrent-rasterbar-1.1.9.tar.gz) = 3903742
+TIMESTAMP = 1538843172
+SHA256 (libtorrent-rasterbar-1.1.10.tar.gz) = 07b2b391e0d16bc693d793e352338488a0e41f3130b70884bb2e0270ea00b8c2
+SIZE (libtorrent-rasterbar-1.1.10.tar.gz) = 3902542
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt b/net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..42fb9c447cd2
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2018-10-06 18:06:13 UTC
++++ CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 3.8)
+ project(libtorrent)
+-set (SOVERSION "8")
++set (SOVERSION "9") # https://github.com/arvidn/libtorrent/issues/3326
+ set (VERSION "1.1.10")
+
+ set(sources
diff --git a/net-p2p/libtorrent-rasterbar/pkg-plist b/net-p2p/libtorrent-rasterbar/pkg-plist
index 8eb932a23427..bf6427544157 100644
--- a/net-p2p/libtorrent-rasterbar/pkg-plist
+++ b/net-p2p/libtorrent-rasterbar/pkg-plist
@@ -1,12 +1,3 @@
-%%TEST%%bin/bt_get
-%%TEST%%bin/bt_get2
-%%TEST%%bin/client_test
-%%TEST%%bin/connection_tester
-%%TEST%%bin/dump_torrent
-%%TEST%%bin/make_torrent
-%%TEST%%bin/simple_client
-%%TEST%%bin/stats_counters
-%%TEST%%bin/upnp_test
include/libtorrent/ConvertUTF.h
include/libtorrent/add_torrent_params.hpp
include/libtorrent/address.hpp
@@ -206,5 +197,4 @@ include/libtorrent/web_peer_connection.hpp
include/libtorrent/xml_parse.hpp
lib/libtorrent-rasterbar.so
lib/libtorrent-rasterbar.so.%%SHLIB_VER%%
-lib/libtorrent-rasterbar.so.%%SHLIB_VER%%.0.0
libdata/pkgconfig/libtorrent-rasterbar.pc
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 60ff69308ab5..37add2203667 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qbittorrent
DISTVERSION= 4.1.3
+PORTREVISION= 1
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/net-p2p/tribler/Makefile b/net-p2p/tribler/Makefile
index 8749f86b2299..65ced705a67a 100644
--- a/net-p2p/tribler/Makefile
+++ b/net-p2p/tribler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tribler
PORTVERSION= 6.5.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Tribler/tribler/releases/download/v${PORTVERSION}/
DISTNAME= Tribler-v${PORTVERSION}