aboutsummaryrefslogtreecommitdiffstats
path: root/net/acx100/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/acx100/Makefile')
-rw-r--r--net/acx100/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/net/acx100/Makefile b/net/acx100/Makefile
new file mode 100644
index 000000000000..3caa27fbea3d
--- /dev/null
+++ b/net/acx100/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: acx100
+# Date created: 2004-07-01
+# Whom: Leonid Zolotarev <leoz@saunalahti.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acx100
+PORTVERSION= 20040701
+CATEGORIES= net
+MASTER_SITES= http://wlan.kewl.org/download/:file_0 \
+ ftp://ftp.dlink.co.uk/wireless/dwl-650+/:file_1
+DISTFILES= ${DISTFILE_0}:file_0 \
+ ${DISTFILE_1}:file_1
+DIST_SUBDIR= acx
+EXTRACT_ONLY= ${DISTFILE_0}
+
+MAINTAINER= leoz@saunalahti.fi
+COMMENT= Texas Instruments (TI) ACX100 IEEE 802.11 driver
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+NO_PACKAGE= This port should be recompiled for a particular FreeBSD kernel
+ONLY_FOR_ARCHS= i386
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN4= if_acx.4
+
+DISTFILE_0= ${DISTNAME}.tgz
+DISTFILE_1= dwl-650+_drv_v3.06_1007_inc_utility.zip
+FIRMWAREDIR= firmware
+INCLUDEDIR= ${PREFIX}/include/acx
+
+pre-fetch:
+.if !exists(${SRC_BASE}/sys/Makefile)
+ @${ECHO} "This port requires the kernel sources to be available"
+.endif
+
+pre-build:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILE_1} ${WRKSRC}/${FIRMWAREDIR} && \
+ cd ${WRKSRC}/${FIRMWAREDIR} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
+
+pre-install:
+ @${INSTALL_MAN} ${WRKSRC}/if_acx.4 ${PREFIX}/man/man4
+#
+# Comment this out when headers will be up to date.
+#
+#.if !exists($INCLUDEDIR})
+# @${MKDIR} ${INCLUDEDIR}
+#.endif
+# @${CP} ${WRKSRC}/include/if_acxioctl.h ${INCLUDEDIR}
+# @${CP} ${WRKSRC}/include/if_acxpacket.h ${INCLUDEDIR}
+#
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501107
+IGNORE= This port requires newer kernel sources that include /sys/dev/owi/if_ieee80211.h
+.endif
+
+.include <bsd.port.post.mk>