aboutsummaryrefslogtreecommitdiffstats
path: root/net/apinger/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/apinger/Makefile')
-rw-r--r--net/apinger/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/apinger/Makefile b/net/apinger/Makefile
index 70f7b0b8b7c8..d62e65003e22 100644
--- a/net/apinger/Makefile
+++ b/net/apinger/Makefile
@@ -17,6 +17,14 @@ COMMENT= An IP device monitoring tool
GNU_CONFIGURE= yes
+OPTIONS= IPV6 "With support for IPv6" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_IPV6)
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
post-extract:
@${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${FILESDIR}/apinger.sh \
> ${WRKSRC}/apinger.sh
@@ -40,4 +48,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}/AUTHORS
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>