aboutsummaryrefslogtreecommitdiffstats
path: root/net/arpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/arpd/Makefile')
-rw-r--r--net/arpd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/arpd/Makefile b/net/arpd/Makefile
new file mode 100644
index 000000000000..1dc4d8b2991b
--- /dev/null
+++ b/net/arpd/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: arpd
+# Date created: 16/04/2002
+# Whom: Dominic Marks <dominic_marks@btinternet.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arpd
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.citi.umich.edu/u/provos/honeyd/
+
+MAINTAINER= dominc_marks@btinternet.com
+
+BUILD_DEPENDS= ${LOCALBASE}/include/dnet.h:${PORTSDIR}/net/libdnet \
+ ${LOCALBASE}/include/event.h:${PORTSDIR}/devel/libevent
+RUN_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
+ ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+
+CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
+ --with-libevent=${LOCALBASE} \
+ --with-pcap
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN8= arpd.8
+
+.include <bsd.port.mk>