aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 9accc66d3a5a..cca83625f01e 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -47,6 +47,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
IODBC "Enable iODBC support" off \
UODBC "Enable unixODBC support" on \
POSTGRES "Enable PostgreSQL support" on \
+ MYSQL "Enable MySQL support" off \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
@@ -153,6 +154,14 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgres
.endif
+.if !defined(WITH_MYSQL)
+PLIST_SUB+= WITH_MYSQL="@comment "
+.else
+PLIST_SUB+= WITH_MYSQL=""
+USE_MYSQL= yes
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-mysql.diff
+.endif
+
.if !defined(WITH_OGGVORBIS)
PLIST_SUB+= WITH_OGGVORBIS="@comment "
CONFIGURE_ARGS+= --without-ogg