aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk14/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk14/Makefile')
-rw-r--r--net/asterisk14/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample