aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk16/Makefile')
-rw-r--r--net/asterisk16/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index bf9289fc189c..00cb6ce94061 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -20,12 +20,10 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
-BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
- mpg123:${PORTSDIR}/audio/mpg123
+BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.3:${PORTSDIR}/audio/speex \
newt.51:${PORTSDIR}/devel/newt
-RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
- mpg123:${PORTSDIR}/audio/mpg123
+RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
ONLY_FOR_ARCHS= i386 sparc64
@@ -71,4 +69,12 @@ RUN_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
PLIST_SUB+= WITH_ZAPTEL=""
.endif
+.if !defined(WITHOUT_MYSQL)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+.endif
+
+post-patch:
+ ${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+
.include <bsd.port.post.mk>