aboutsummaryrefslogtreecommitdiffstats
path: root/net/bird/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/bird/Makefile')
-rw-r--r--net/bird/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index d98ad44093f5..bd3b413ec0c7 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bird
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
@@ -18,7 +19,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
OPTIONS= FIBS "Enable multiple fib support" Off \
- LEARN_FIX "Support multiple routing daemons" Off
+ CONFIG_INCLUDES "Permit config 'include' keyword" Off
MAKE_JOBS_UNSAFE= yes
@@ -30,13 +31,24 @@ USE_RC_SUBR= bird
EXTRA_PATCHES+= ${FILESDIR}/fibs.diff
.endif
-.if defined(WITH_LEARN_FIX)
-EXTRA_PATCHES+= ${FILESDIR}/learn-krt-sock.c
+.if defined(WITH_CONFIG_INCLUDES)
+EXTRA_PATCHES+= ${FILESDIR}/extra-config_includes.diff
.endif
post-install:
@if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
+ ${CHMOD} 0640 ${PREFIX}/etc/bird.conf ; \
fi
+.if defined(WITH_FIBS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} =====================================================================
+ @${ECHO_MSG}
+ @${ECHO_MSG} " WARNING: Please take a look on kern/134931"
+ @${ECHO_MSG} " WARNING: before using multiple fibs in production!"
+ @${ECHO_MSG}
+ @${ECHO_MSG} =====================================================================
+ @${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>