aboutsummaryrefslogtreecommitdiffstats
path: root/net/bird/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/bird/Makefile')
-rw-r--r--net/bird/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 28a8012e1c94..d98ad44093f5 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -6,24 +6,37 @@
#
PORTNAME= bird
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.1
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
-MAINTAINER= pav@FreeBSD.org
+MAINTAINER= melifaro@ipfw.ru
COMMENT= Dynamic IP routing daemon (IPv4 version)
USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
+OPTIONS= FIBS "Enable multiple fib support" Off \
+ LEARN_FIX "Support multiple routing daemons" Off
+
MAKE_JOBS_UNSAFE= yes
USE_RC_SUBR= bird
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FIBS)
+EXTRA_PATCHES+= ${FILESDIR}/fibs.diff
+.endif
+
+.if defined(WITH_LEARN_FIX)
+EXTRA_PATCHES+= ${FILESDIR}/learn-krt-sock.c
+.endif
+
post-install:
@if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>