aboutsummaryrefslogtreecommitdiffstats
path: root/net/boinc-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/boinc-client/Makefile')
-rw-r--r--net/boinc-client/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index d0b62ac2de20..bbea8841ed2e 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -32,7 +32,10 @@ SUB_LIST= BOINC_HOME="${BOINC_HOME}" BOINC_USER="${BOINC_USER}" BOINC_GROUP="${B
USE_RC_SUBR= boinc.sh
CONFIGURE_ARGS= --disable-server
-CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include CXXFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include -O3" CFLAGS="${CFLAGS} -O3"
+CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS:= ${CXXFLAGS:N-O*:N-f*} -O3
+CFLAGS:= ${CFLAGS:N-O*:N-f*} -O3
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGSS="${CXXFLAGS}" CFLAGS="${CFLAGS}"
OPTIONS= X11 "Build Boinc Manager GUI" on
@@ -40,6 +43,7 @@ OPTIONS= X11 "Build Boinc Manager GUI" on
.if !defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
+CPPFLAGS+= -I${X11BASE}/include
.else
CONFIGURE_ARGS+= --with-wx-config=false
.endif