aboutsummaryrefslogtreecommitdiffstats
path: root/net/cyphesis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/cyphesis/Makefile')
-rw-r--r--net/cyphesis/Makefile44
1 files changed, 22 insertions, 22 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index 9d162ca4fc41..5ac8cd01f5f6 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -1,14 +1,9 @@
-
-# New ports collection makefile for: cyphesis
-# Date created: 02 Oct 2005
-# Whom: Oliver Lehmann <oliver@FreeBSD.org>
-#
+# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cyphesis
-PORTVERSION= 0.5.26
-PORTREVISION= 2
+PORTVERSION= 0.6.0
+#PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
@@ -16,11 +11,12 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= A server for WorldForge games
LIB_DEPENDS= Atlas-0.6.1:${PORTSDIR}/devel/atlas-devel \
- varconf-1.0.7:${PORTSDIR}/devel/varconf \
- wfmath-0.3.5:${PORTSDIR}/math/wfmath \
- mercator-0.3.1:${PORTSDIR}/devel/mercator \
- skstream-0.3.6:${PORTSDIR}/net/skstream \
- gcrypt.18:${PORTSDIR}/security/libgcrypt
+ varconf-1.0.8:${PORTSDIR}/devel/varconf \
+ wfmath-1.0.1:${PORTSDIR}/math/wfmath \
+ mercator-0.3.3:${PORTSDIR}/devel/mercator \
+ skstream-0.3.7:${PORTSDIR}/net/skstream \
+ gcrypt.18:${PORTSDIR}/security/libgcrypt \
+ boost_regex:${PORTSDIR}/devel/boost-libs
CONFIGURE_ARGS= --with-python=${LOCALBASE}
@@ -31,34 +27,38 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PGSQL= yes
USE_PYTHON= 2.5-2.6
+USE_GCC= 4.7+
CFLAGS+= -I${LOCALBASE}/include
MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
cyconvertrules.1 cydumprules.1 cyloadrules.1 cypasswd.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' ${WRKSRC}/data/Makefile.in
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' \
+ ${WRKSRC}/data/minimal/Makefile.in \
+ ${WRKSRC}/data/mars/Makefile.in \
+ ${WRKSRC}/data/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lpython|${PTHREAD_LIBS} &|' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
- ${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g'
+ ${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g ; \
+ s|confbackupdir = .*|confbackupdir = ${DOCSDIR}/conf|g'
@${REINPLACE_CMD} -e 's|/bash|/sh|' ${WRKSRC}/scripts/extract_revision.sh
@${REINPLACE_CMD} -e '1s|python|${LOCALBASE}/bin/${PYTHON_VERSION}|' ${WRKSRC}/scripts/gen_buildid.py
@${REINPLACE_CMD} -e 's/#ifdef __APPLE__/#if defined(__APPLE__) || defined(__FreeBSD__)/g; \
s/#ifndef __APPLE__/#if !defined(__APPLE__) \&\& !defined(__FreeBSD__)/g' \
${WRKSRC}/common/system.cpp \
- ${WRKSRC}/common/AtlasStreamClient.cpp \
${WRKSRC}/server/CommUnixListener.cpp
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/conf
-.for docfile in README COPYING AUTHORS THANKS NEWS ChangeLog TODO
+.for docfile in README COPYING AUTHORS THANKS NEWS ChangeLog TODO FIXME
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.for docfile in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
@@ -66,4 +66,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>