aboutsummaryrefslogtreecommitdiffstats
path: root/net/dgd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/dgd/Makefile')
-rw-r--r--net/dgd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/dgd/Makefile b/net/dgd/Makefile
index aa73e59c59c0..750915d1ef5e 100644
--- a/net/dgd/Makefile
+++ b/net/dgd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dgd
-PORTVERSION= 1.4.8
+PORTVERSION= 1.4.11
CATEGORIES= net lang games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S|%SUBDIR%|${PORTNAME}-osr|} \
${MASTER_SITE_SOURCEFORGE:S|%SUBDIR%|${PORTNAME}-osr/old|}
@@ -18,6 +18,7 @@ LICENSE= GPLv3
OPTIONS= NETWORKING "With networking kfuns" off \
DUMP "With dump kfuns" off \
+ CLOSURES "With function pointer support" off \
LPC_EXTENSION "With LPC extension interface" off
DIST_SUBDIR= dgd
@@ -47,6 +48,10 @@ EXTRA_DEFINES+= -DDUMP_FUNCS
EXTRA_DEFINES+= -DLPC_EXTENSION
.endif
+.if defined(WITH_CLOSURES)
+EXTRA_DEFINES+= -DCLOSURES
+.endif
+
post-patch:
@${MV} ${WRKSRC}/host/Makefile.bsd ${WRKSRC}/host/Makefile
@cd ${WRKDIR}/dgd/ && ${FIND} . -name '*.orig' -delete