aboutsummaryrefslogtreecommitdiffstats
path: root/net/everybuddy
diff options
context:
space:
mode:
Diffstat (limited to 'net/everybuddy')
-rw-r--r--net/everybuddy/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/everybuddy/Makefile b/net/everybuddy/Makefile
index c08f25690ee7..11bdbad5df59 100644
--- a/net/everybuddy/Makefile
+++ b/net/everybuddy/Makefile
@@ -17,10 +17,12 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GTK= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
MAN1= everybuddy.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
+ s|-lpthreads|${PTHREAD_LIBS:S/"//g}|g' ${WRKSRC}/configure
.include <bsd.port.mk>