aboutsummaryrefslogtreecommitdiffstats
path: root/net/fspd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/fspd/Makefile')
-rw-r--r--net/fspd/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/fspd/Makefile b/net/fspd/Makefile
index db23b0950082..04c4f46ed03a 100644
--- a/net/fspd/Makefile
+++ b/net/fspd/Makefile
@@ -34,16 +34,17 @@ USE_SCONS= yes
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
-OPTIONS= NOCLIENTS "Omit client commands" off \
- INFINITE "Infinite retry in client commands" off
+OPTIONS_DEFINE= NOCLIENTS INFINITE
+NOCLIENTS_DESC= Omit client commands
+INFINITE_DESC= Infinite retry in client commands
.include <bsd.port.pre.mk>
-.if defined(WITH_INFINITE)
+.if ${PORT_OPTIONS:MINFINITE}
SCONS_ARGS+= disable-timeout=yes
.endif
-.if !defined(WITH_NOCLIENTS)
+.if ! ${PORT_OPTIONS:MNOCLIENTS}
.for command in ${CLIENTS}
PLIST_FILES+= bin/${command}
.endfor
@@ -61,13 +62,13 @@ post-build:
@${CP} ${WRKSRC}/doc/*.html ${WRKSRC}
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
-.if !defined(WITH_NOCLIENTS)
+.if ! ${PORT_OPTIONS:MNOCLIENTS}
.for command in ${CLIENTS}
${INSTALL_PROGRAM} ${WRKSRC}/clients/${command} ${PREFIX}/bin
.endfor