aboutsummaryrefslogtreecommitdiffstats
path: root/net/geocode-glib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/geocode-glib/Makefile')
-rw-r--r--net/geocode-glib/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/net/geocode-glib/Makefile b/net/geocode-glib/Makefile
index e62809b8b811..069bb62240ea 100644
--- a/net/geocode-glib/Makefile
+++ b/net/geocode-glib/Makefile
@@ -2,25 +2,23 @@
# $FreeBSD$
PORTNAME= geocode-glib
-PORTVERSION= 3.18.2
+PORTVERSION= 3.26.0
CATEGORIES= net devel gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Convenience library for the geocoding and reverse geocoding
+BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
libsoup-2.4.so:devel/libsoup
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
-USE_GNOME= intlhack
+USES= gettext gnome localbase meson pkgconfig tar:xz
+USE_GNOME= glib20 introspection:build
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
-INSTALL_TARGET= install-strip
+MESON_ARGS= -Denable-installed-tests=false
+#MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
.include <bsd.port.mk>