aboutsummaryrefslogtreecommitdiffstats
path: root/net/gnomenettool
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnomenettool')
-rw-r--r--net/gnomenettool/Makefile1
-rw-r--r--net/gnomenettool/files/patch-src_info.c4
2 files changed, 3 insertions, 2 deletions
diff --git a/net/gnomenettool/Makefile b/net/gnomenettool/Makefile
index 5d49f0c0725c..88dfb07f5e00 100644
--- a/net/gnomenettool/Makefile
+++ b/net/gnomenettool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomenettool
PORTVERSION= 0.99.1
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-nettool/0.99
diff --git a/net/gnomenettool/files/patch-src_info.c b/net/gnomenettool/files/patch-src_info.c
index 7b6e43a5fcf4..d5602ae5be80 100644
--- a/net/gnomenettool/files/patch-src_info.c
+++ b/net/gnomenettool/files/patch-src_info.c
@@ -1,5 +1,5 @@
--- src/info.c.orig Fri Jun 11 07:14:17 2004
-+++ src/info.c Mon Jul 5 15:25:09 2004
++++ src/info.c Tue Jul 6 01:19:20 2004
@@ -37,6 +37,9 @@
#include <sys/ioctl.h>
#include <stdlib.h>
@@ -132,7 +132,7 @@
compressed, multicast,
tx_bytes, tx_pkt, tx_error, tx_drop, tx_fifo, collissions);
+#elif defined(__FreeBSD__)
-+ tokens = (gchar **) g_malloc0 ((sizeof (char)) * (strlen (line) + 2));
++ tokens = (gchar **) g_malloc0 (sizeof (gchar *) * 12);
+ p = strtok (line, " \t\n");
+ /* We only care about 11 fields for now */
+ for (i = 0; i < 11 && p; i++, p = strtok (NULL, " \t\n")) {