aboutsummaryrefslogtreecommitdiffstats
path: root/net/gofish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gofish/Makefile')
-rw-r--r--net/gofish/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/net/gofish/Makefile b/net/gofish/Makefile
index b77430c30146..841a0f1317c8 100644
--- a/net/gofish/Makefile
+++ b/net/gofish/Makefile
@@ -7,21 +7,35 @@
#
PORTNAME= gofish
-PORTVERSION= 0.29
+PORTVERSION= 1.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kaiw27@gmail.com
COMMENT= GoFish Gopher Server
+WRKSRC= ${WRKDIR}/${PORTNAME}
GOPHERROOT?= ${PREFIX}/gopher
GOPHERUSER?= nobody
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gopherroot=${GOPHERROOT} \
--with-gopheruser=${GOPHERUSER}
+MAKE_ENV= localstatedir=/var
-MAN1= gmap2cache.1 gofish.1 gopherd.1 mkcache.1
-MAN5= dotcache.5 gofish.5
+MAN1= gofish.1 mkcache.1
+MAN5= dotcache.5 gofish.5
+MLINKS= gofish.1 gopherd.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-install:
+.for i in ${PREFIX}/etc/gofish.conf ${PREFIX}/etc/gofish-www.conf
+ if test -f ${i}.new; then \
+ ${MV} ${i}.new ${i}.sample; \
+ else \
+ ${CP} -p ${i} ${i}.sample; \
+ fi
+.endfor
+
+.include <bsd.port.post.mk>