aboutsummaryrefslogtreecommitdiffstats
path: root/net/grilo2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/grilo2/Makefile')
-rw-r--r--net/grilo2/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/grilo2/Makefile b/net/grilo2/Makefile
new file mode 100644
index 000000000000..3cd777ed0cb9
--- /dev/null
+++ b/net/grilo2/Makefile
@@ -0,0 +1,37 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+
+PORTNAME= grilo
+PORTVERSION= 0.2.15
+CATEGORIES= net
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Grilo is a framework focused on making media discovery and browsing
+
+BUILD_DEPENDS= vapigen:lang/vala
+LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
+ liboauth.so:net/liboauth \
+ libtotem-plparser.so:multimedia/totem-pl-parser
+
+USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+USE_GNOME= glib20 intlhack introspection:build libxml2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-vala -disable-debug
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+# --enable-debug include debug symbols
+CONFIGURE_ARGS+=--enable-tests # build unit tests
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= UI
+
+UI_DESC= Enable testing UI
+UI_CONFIGURE_ENABLE=test-ui
+UI_USE= GNOME=gtk30
+
+.include <bsd.port.mk>