aboutsummaryrefslogtreecommitdiffstats
path: root/net/happystats
diff options
context:
space:
mode:
Diffstat (limited to 'net/happystats')
-rw-r--r--net/happystats/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net/happystats/Makefile b/net/happystats/Makefile
index c3dcb263247a..8727efff6ac1 100644
--- a/net/happystats/Makefile
+++ b/net/happystats/Makefile
@@ -16,12 +16,12 @@ MAINTAINER= kiwi@oav.net
COMMENT= Universal log converter into graph
BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
-
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
xml2.5:${PORTSDIR}/textproc/libxml2 \
rrd.0:${PORTSDIR}/net/rrdtool
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
MAN1= happystats.1
MANCOMPRESSED= yes
@@ -29,13 +29,14 @@ DOCS= AUTHORS INSTALL TODO
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502108
-BROKEN= "Does not link on FreeBSD >= 5.x"
-.endif
-
do-configure:
@cd ${WRKSRC} && ${MAKE} dep
+post-configure:
+.if ${OSVERSION} > 500041
+ @${REINPLACE_CMD} -E -e 's|-lgnugetopt||g' ${WRKSRC}/Makefile
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/happystats ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/happystats.1.gz ${MAN1PREFIX}/man/man1