aboutsummaryrefslogtreecommitdiffstats
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 7259400f3111..67bd719e8d94 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -18,7 +18,7 @@ CONFLICTS_INSTALL= haproxy-devel-[0-9]*
USES= cpe gmake
USE_RC_SUBR= haproxy
-DEVICEATLAS_VERSION= 2.1
+DEVICEATLAS_VERSION= 2.1.1
DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
@@ -46,12 +46,12 @@ MAKE_ARGS+= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.endif
.if ${PORT_OPTIONS:MDEVICEATLAS}
-.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.zip)
+.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.tgz)
IGNORE?= you must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
.else
RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
-DISTFILES+= ${DEVICEATLAS_DISTFILE}.zip
-MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
+DISTFILES+= ${DEVICEATLAS_DISTFILE}.tgz
+MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}/Src
.endif
.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
IGNORE?= enable PCRE support to use DeviceAtlas