aboutsummaryrefslogtreecommitdiffstats
path: root/net/honeyd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/honeyd/Makefile')
-rw-r--r--net/honeyd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index a0446276ef3f..c3337cfa5b83 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= honeyd
PORTVERSION= 1.5c
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= http://www.honeyd.org/uploads/ \
http://www.citi.umich.edu/u/provos/honeyd/
@@ -13,7 +13,7 @@ COMMENT= Simulate virtual network hosts (honeypots)
LICENSE= GPLv2
-LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent \
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2 \
libdnet.so:${PORTSDIR}/net/libdnet \
libpcre.so:${PORTSDIR}/devel/pcre
@@ -23,6 +23,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
--with-libevent=${LOCALBASE}
+EXTRA_PATCHES= ${FILESDIR}/honeyd-1.5c-libevent2.patch:-p1
+
.if defined(WITH_PYTHON)
USE_PYTHON= yes
CONFIGURE_ARGS+= --with-python