aboutsummaryrefslogtreecommitdiffstats
path: root/net/httping/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/httping/Makefile')
-rw-r--r--net/httping/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index f81ed50e113b..e5d2d2b4d659 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httping
-PORTVERSION= 1.2.4
+PORTVERSION= 1.2.5
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
http://critical.ch/distfiles/ \
@@ -19,6 +19,11 @@ COMMENT= A ping-like tool for HTTP requests
MAN1= httping.1
PLIST_FILES= bin/httping
+CFLAGS+= -DVERSION=\\\"${PORTVERSION}\\\"
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^(DEBUG|CFLAGS)/d' ${WRKSRC}/${MAKEFILE}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1