aboutsummaryrefslogtreecommitdiffstats
path: root/net/ipcheck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ipcheck/Makefile')
-rw-r--r--net/ipcheck/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/ipcheck/Makefile b/net/ipcheck/Makefile
new file mode 100644
index 000000000000..387133f92765
--- /dev/null
+++ b/net/ipcheck/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ipcheck
+# Date created: 24 Mar 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipcheck
+PORTVERSION= 0.85
+CATEGORIES= net
+MASTER_SITES= http://ipcheck.sourceforge.net/
+DISTNAME= ipcheck.py
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-patch:
+ @${SED} -e "s!/usr/bin/python!${LOCALBASE}/bin/python!" \
+ -e "s!ppp0!tun0!" \
+ ${DISTDIR}/${DISTNAME} > ${WRKDIR}/${DISTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>