aboutsummaryrefslogtreecommitdiffstats
path: root/net/jit
diff options
context:
space:
mode:
Diffstat (limited to 'net/jit')
-rw-r--r--net/jit/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/jit/Makefile b/net/jit/Makefile
index b7c2de007448..cc3cbbb9f874 100644
--- a/net/jit/Makefile
+++ b/net/jit/Makefile
@@ -18,6 +18,12 @@ USE_GMAKE= yes
USE_REINPLACE= yes
HAS_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 or ia64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/jit/jabber-icq.example ${WRKSRC}/jit/jit.sh
@@ -33,4 +39,4 @@ do-install:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>