aboutsummaryrefslogtreecommitdiffstats
path: root/net/l4ip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/l4ip/Makefile')
-rw-r--r--net/l4ip/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/l4ip/Makefile b/net/l4ip/Makefile
new file mode 100644
index 000000000000..594daf563378
--- /dev/null
+++ b/net/l4ip/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: l4ip
+# Date created: 17 February 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= l4ip
+PORTVERSION= 1.0.294
+CATEGORIES= net
+MASTER_SITES= http://www.lundman.net/ftp/l4ip/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/([0-9]*)\.([0-9]*)\.([0-9]*)/v\1.\2.b\3/}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= L4 and Health-Check project for IPFilter
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,service_type_t,script_type_t,g' ${WRKSRC}/service.c
+ ${REINPLACE_CMD} -e 's,/usr/sbin,/sbin,g' ${WRKSRC}/l4ip.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/l4ip ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/l4ip.conf ${PREFIX}/etc
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL} ${WRKSRC}/../samples/*.conf ${EXAMPLESDIR}
+
+.include <bsd.port.mk>