aboutsummaryrefslogtreecommitdiffstats
path: root/net/libdnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libdnet/Makefile')
-rw-r--r--net/libdnet/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index 80d1b2f9e959..f11f8fcecc22 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -11,17 +11,13 @@ MAINTAINER?= onatan@gmail.com
COMMENT= A simple interface to low level networking routines
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
.if !defined(LIBDNET_SLAVE)
CONFIGURE_ARGS+= --without-python
USE_LDCONFIG= yes
-
-MAN3= dnet.3
-MAN8= dnet.8
.endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !defined(LIBDNET_SLAVE)
@@ -33,8 +29,8 @@ post-build:
@cd ${WRKSRC}/src ; ${CC} ${CFLAGS} -shared -o libdnet.so .libs/addr-util.o .libs/addr.o .libs/blob.o .libs/ip-util.o .libs/ip6.o .libs/rand.o .libs/arp-bsd.o .libs/eth-bsd.o .libs/fw-pf.o .libs/intf.o .libs/ip.o .libs/route-bsd.o .libs/tun-bsd.o
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib/
- @${LN} ${PREFIX}/lib/${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/
+ @${LN} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so.1
.endif
.include <bsd.port.post.mk>