aboutsummaryrefslogtreecommitdiffstats
path: root/net/librsync/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/librsync/Makefile')
-rw-r--r--net/librsync/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
index f89107311454..66377cf4ac76 100644
--- a/net/librsync/Makefile
+++ b/net/librsync/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= librsync
-PORTVERSION= 0.9.5.1
+PORTVERSION= 0.9.6
CATEGORIES= net
-MASTER_SITES= http://rdiff-backup.stanford.edu/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for delta compression of streams
@@ -19,14 +20,18 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
+USE_REINPLACE= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-shared --disable-trace
-USE_GMAKE= yes
INSTALLS_SHLIB= yes
-MAN1= rdiff.1
MAN3= librsync.3
+post-patch:
+ @${REINPLACE_CMD} -e 's|= rdiff.1|=|g' ${WRKSRC}/doc/Makefile.in
+
.include <bsd.port.mk>