aboutsummaryrefslogtreecommitdiffstats
path: root/net/libsocketcpp
diff options
context:
space:
mode:
Diffstat (limited to 'net/libsocketcpp')
-rw-r--r--net/libsocketcpp/Makefile20
-rw-r--r--net/libsocketcpp/distinfo1
-rw-r--r--net/libsocketcpp/pkg-comment1
-rw-r--r--net/libsocketcpp/pkg-descr4
-rw-r--r--net/libsocketcpp/pkg-plist8
5 files changed, 34 insertions, 0 deletions
diff --git a/net/libsocketcpp/Makefile b/net/libsocketcpp/Makefile
new file mode 100644
index 000000000000..3c7e5806a44d
--- /dev/null
+++ b/net/libsocketcpp/Makefile
@@ -0,0 +1,20 @@
+# ex:ts=8
+# New ports collection makefile for: libsocketcpp
+# Date created: Aug 12, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsocketcpp
+PORTVERSION= 1.0.6
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libsocket
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/net/libsocketcpp/distinfo b/net/libsocketcpp/distinfo
new file mode 100644
index 000000000000..c2117a9e7907
--- /dev/null
+++ b/net/libsocketcpp/distinfo
@@ -0,0 +1 @@
+MD5 (libsocketcpp-1.0.6.tar.gz) = 3764daf2adaa8c44cd4ac6dfec027fd3
diff --git a/net/libsocketcpp/pkg-comment b/net/libsocketcpp/pkg-comment
new file mode 100644
index 000000000000..ff3133940fc7
--- /dev/null
+++ b/net/libsocketcpp/pkg-comment
@@ -0,0 +1 @@
+A C++ wrapper library to the sockets
diff --git a/net/libsocketcpp/pkg-descr b/net/libsocketcpp/pkg-descr
new file mode 100644
index 000000000000..ad51367d205e
--- /dev/null
+++ b/net/libsocketcpp/pkg-descr
@@ -0,0 +1,4 @@
+Libsocketcpp provides a easy-to-use C++ class. With this class, TCP and UDP
+functionality can be added to any program quickly and easily.
+
+WWW: http://libsocket.sourceforge.net/
diff --git a/net/libsocketcpp/pkg-plist b/net/libsocketcpp/pkg-plist
new file mode 100644
index 000000000000..fc3f30f6c03c
--- /dev/null
+++ b/net/libsocketcpp/pkg-plist
@@ -0,0 +1,8 @@
+bin/tcpservertest
+bin/tcptest
+include/libsocketcpp/tcpsocket.h
+lib/libsocketcpp.a
+lib/libsocketcpp.la
+lib/libsocketcpp.so
+lib/libsocketcpp.so.0
+@dirrm include/libsocketcpp